Getting started

This guide walks you through all of the things you can do with Anaconda Enterprise. We recommend that you do each step in Enterprise as you walk through this guide.

See also the Quick Start guide for the fastest way to try out the power of Enterprise.

In this Getting started guide you will create a new Anaconda Project, open it in JupyterLab or classic Jupyter Notebook and upload a notebook to your project.

Then you’ll take a peek at the file that governs your Project, the anaconda-project.yml.

After that you’ll use the Project interface to easily add a download, a channel and a package. Then you will use the same interface to prepare an environment and link the notebook to it.

Next you’ll add and save a deployable command and run the project.

Finally you will deploy the project and share it with others.

Getting started steps

Before you start

You should have already received a welcome email from your system administrator with a link to your Enterprise site, your username and password. Click the link and enter your username or email address and password, then click the Login button:

../../_images/ae50-new-login.png

NOTE: If your administrator enabled self-registration, you will create your own username and password. Enter the following information to register:

../../_images/ae50-register.png

Now you are at the Anaconda Enterprise dashboard, which displays a list of all your Anaconda Projects.

../../_images/ae50-home.png

Create an Anaconda Project

Anaconda Project encapsulates data science projects to make them easily portable. Project automates all your setup steps such as installing the right packages, downloading files, setting environment variables and running commands.

Let’s create a new Project named finance_notebook.

On the Projects list, click the top left Add (+) button and select New Project.

../../_images/ae50-new-project1.png

Name your new project “finance_notebook”. Click the Next button.

../../_images/ae50-createproject2.png

You can choose among several types of projects, including Anaconda 3, Anaconda 2, R Language, SAS and Spark.

For this exercise select Anaconda 3.6, then click the Create button. After the project is created, click the Launch JupyterLab link.

../../_images/ae50-new-project4.png

Anaconda Enterprise prepares your Project, copying all the necessary files into it, so this will take a minute.

TIP: While it’s running, download and check out the handy JupyterLab and Jupyter Notebook cheat sheet.

Open the Project in JupyterLab

If you have clicked the view button in the previous step, click the top right OPEN IN JUPYTERLAB button or click the arrow next to it and select “Open in classic Notebook”.

../../_images/ae50-open-jupyterlab.png

Add a notebook

You can use JupyterLab to create new notebooks or edit existing notebooks.

To see the data science capabilities of the Anaconda Enterprise, you can play with a large notebook that is already written for you. The Markowitz Notebook is based on a classic financial theory for maximizing portfolio return.

Click this link to download the Markowitz notebook to your computer.

Next, upload the Markowitz notebook to Enterprise from the Files tab by clicking the Upload File(s) icon at the top:

../../_images/ae50-get-started-upload.png

To see the uploaded file, click the left FILES tab. The uploaded Notebook appears in the file list:

See how Anaconda Projects work

Open the anaconda-project.yml file now to take a look at it:

../../_images/ae50-ap-yaml.png

This file shows everything that was automatically created when you launched your new project.

If you wanted to make changes to your Project file, you would click the left Project tab. You are not making changes now, so close the tab by clicking the X on the top tab in the right pane.

Add a download

Now let’s say you want a file to be automatically downloaded when you run the notebook, so you will add a download to it.

On the left Project tab, find the “DOWNLOADS” field, click its Add (+) icon and add a file for the notebook to download.

Copy and paste this into the URL box: http://pastebin.com/raw/BX9mBNhL

In the Name box enter “MARKOWITZ” and in the local file box enter “markowitz.csv”. Click the Save button.

Save all your changes by clicking the blue-highlighted “Project Save” button at the top right of this pane.

../../_images/ae50-download.png

Add a channel

Add the R Language channel to this Project so you can search, download and install packages from this specific channel.

In the left Project tab, open the CHANNELS field with the pencil icon next to it.

Then copy and paste this link: https://conda.anaconda.org/r

Click the Add (+) icon to add the channel, then click the blue-highlighted “Project Save” button at the top right of this pane.

../../_images/ae50-add-channel.png

Add packages

In the left Project tab, find the “PACKAGES” field and click its edit icon, the pencil, to add packages. You are not using any packages for this project.

markowitz.ipynb uses the following packages which are installed with Anaconda 3.6:

  • notebook
  • pandas
  • bokeh
  • tornado
  • numpy
  • ipykernel
  • r
  • rpy2

To save your Project, click the “Save Project Data” icon on the top right corner of the left panel, NOT the “Save Notebook” icon at the far right of the page.

Prepare all environments

Now that you’ve added all these goodies to your Project, it’s time to link the notebook to your Project environment.

Still on the left Project tab, find the ENVIRONMENTS field and click the “Prepare All Environments” button next to the Add (+) icon.

../../_images/ae50-prepenv.png

Run the Notebook

Click the left Files tab, then double-click the icon to the left of the name “markowitz.ipynb” to open it.

Click the top “Notebook” menu, and from the drop-down select “Run All Cells”.

../../_images/ae50-gs-runnotebook.png

Deploy the Project

To deploy your project, you will add a deployable command and save, then leave JupyterLab and deploy the project using the Anaconda Enterprise interface.

Add a deploy command

Any project you want to deploy needs to have a deployable command for it to run.

From the Project tab (not Commands tab), find the “COMMANDS” field and click its Add (+) icon.

In the Type section click “Notebook”

In the Name box enter “default”

In the notebook box enter “markowitz.ipynb”

Click the Save button.

../../_images/ae50-deploy.png

Save the Deployment

In the top navigation bar on the far right, click the save icon and then click next to save the Project.

Deploy it

Exit the Notebook with the “Back to finance_notebook” link on the top left corner, then click the left Deploy tab.

Click the Deploy button.

While it is deploying, click the Deployment History tab. There you can see a counter, then a pop-up telling you it has deployed.

Interact with Deployment

In the Deployments list, click the finance_notebook link to view and interact with your deployment. In the View tab you can choose Cell, All Output, and Clear to clear the output. Then run all cells in your notebook with Cell and Run All.

Share your Deployment

In the Deployments list, click the name of the Deployment to share, then click the Share tab. In the box that appears, begin typing the username of your collaborator with whom you wish to share, select their name from the drop-down list and click the Share button.

Your collaborator appears in the Existing Collaborators list below.

../../_images/ae50-share-project.png

When your Collaborator logs onto Enterprise, they will see the new Deployment in their Deployments list.