Getting started

This 20-minute getting started guide walks you through all of the things you can do with Anaconda Enterprise. We recommend that you do each step hands-on in Enterprise as you walk through this guide.

You can choose to deploy and share an existing Anaconda Project, or jump right into creating and editing a new project.

TIP: Download the Cheat Sheet for handy reference while you work through the steps.

Getting started steps

Before you start

You will have already received a welcome email from your system administrator with a link to your Enterprise site, your username and password. Click the link and enter your username or email address and password, then click the Login button:

../../_images/ae50-new-login.png

NOTE: If your administrator enabled self-registration, you can create your own username and password. Enter the following information to register:

../../_images/ae50-register.png

Now you are at the Anaconda Enterprise dashboard, which displays a list of all your Anaconda Projects.

../../_images/ae52-project-list.png

Deploy a sample project

Enterprise includes many types of sample projects for you to use for testing and to use as recipes.

To open a sample project, click the top right “Sample Projects” link. Scroll to find the project named “data_crossfilter” and click the “Save to My Projects” link.

../../_images/ae52-project-list.png

Then return to the Projects list by clicking the top left “Back to My Projects” link.

Select the Data Crossfilter project by clicking its name.

Deploy your Project

To Deploy the Data Crossfilter project, from the left navigation click the Deploy tab.

Accept the Project’s default settings by clicking the Deploy button.

../../_images/ae52-deploy-project.png

After Enterprise finishes deploying, click the Done button to view the deployment.

../../_images/ae52-qs-deployment-starting.png

Interact with your Deployment

Immediately you can interact with your new Deployment.

You can interact with any widgets included in the Project. Change the color and size of the dots, or change the axes that are displayed.

../../_images/ae52-qs-deployment-started.png

Share your Deployment with others

You can easily share your Deployment with other Enterprise users.

From the left menu click Share, then in the Add New Collaborator box begin typing the name of another Enterprise user. Select the name of the user with whom you want to share, then click the Share button.

../../_images/ae52-share-deployment.png

When your collaborator logs onto Enterprise, they will see the new Deployment in their Deployments list.

../../_images/ae52-qs-collaborator-deployment-list.png

Clicking on the the deployment allows your collaborator to interact with widgets. They cannot share, view logs, or terminate the deployment.

../../_images/ae52-qs-collaborator-deployment-widgets.png

NOTE: If you change the state of the widgets before sharing, the changed state is not shared between collaborators.

Create an Anaconda Project

In this exercise you will create a new Anaconda Project, open it in an editing session, and upload a notebook to your project.

Then you’ll take a peek at the file that governs your Project, the anaconda-project.yml.

After that you’ll use the Project interface to easily add a download, a channel and a package, prepare an environment and link the notebook to it.

Next you’ll add a deployable command, commit the changes, and run your project.

Finally you will deploy the project and share it with other Enterprise users.

To get started, on the Projects list, click the top left Add (+) button and select New Project.

../../_images/ae50-new-project1.png

Name your new project “finance_notebook”. Click the Next button.

../../_images/ae52-new-project2.png

You can choose among several types of projects, including Anaconda 3, Anaconda 2, R Language, SAS and Spark.

Select Anaconda 3.6 and click the Create button.

../../_images/ae52-new-project3.png

Anaconda Enterprise takes a minute to prepare your Project and copy in all the necessary files.

../../_images/ae52-new-project4.png

TIP: While it’s running, download and check out the handy JupyterLab and Jupyter Notebook cheat sheet.

Launch an Editing Session

Click the LAUNCH SESSION link.

../../_images/ae52-new-project5.png

SEE ALSO: Launch Editing Session.

Add a notebook

You can use JupyterLab to create new notebooks or edit existing notebooks.

To see the data science capabilities of the Anaconda Enterprise, you can play with a large notebook that is already written for you. The Intro to Data Analysis Notebook is based on a classic titanic data analysis problem. Let’s say a friend or colleague gave you this notebook, and you want to add it to this project.

Click this link to download the Markowitz notebook to your computer.

Next, upload the Markowitz notebook to your Project. Click the left Files tab, then click the Upload File(s) icon at the top:

../../_images/ae50-get-started-upload.png

To see the uploaded file, click the left FILES tab. The uploaded Notebook appears in the file list.

See how Anaconda Projects work

Open the anaconda-project.yml configuration file now to take a look at it:

../../_images/ae52-ap-yaml.png

This file shows everything that was automatically created when you launched your new project.

If you wanted to make changes to your Project file, you would click the left Project tab.

Add a download

Now let’s say you want a file to be automatically downloaded when you run the notebook, so now you will add a download to this project.

On the left Project tab, find the “DOWNLOADS” field, click its Add (+) icon and add a file for the notebook to download.

Copy and paste this into the URL box: http://pastebin.com/raw/BX9mBNhL

In the Name box enter “MARKOWITZ” and in the local file box enter “markowitz.csv”. Click the Save button.

Save all your changes by clicking the blue-highlighted “Project Save” button at the top right of this pane.

../../_images/ae50-download.png

NOTE: In an air gapped environment, click this link to download the Markowitz data to your computer and then upload it in the same way you did the notebook.

Add a channel

Add the R Language Channel to this Project so you can easily search, download and install packages from this specific channel when using this project.

In the left Project tab, open the CHANNELS field with the pencil icon next to it.

Then copy and paste this link: https://conda.anaconda.org/r

Click the Add (+) icon to add the channel, then click the blue-highlighted “Project Save” button at the top right of this pane.

../../_images/ae51-add-channel.png

Add packages

Add a Package to this project. In the left Project tab, find the “PACKAGES” field and click its edit icon, the pencil, to add packages. Adding packages here adds them to your anaconda-project.yml configuration file. You may edit that file directly if you prefer.

markowitz.ipynb uses the following packages which are already installed with Anaconda 3.6. Optionally, the notebook can depend on R. If you set use_R = True in the first cell, then you should add the following packages:

  • r
  • rpy2

After adding packages, click the “Save Project Data” icon in your left panel on the top right corner. This saves your project locally.

Prepare all environments

Now that you’ve added all these goodies to your Project, it’s time to link the notebook to your Project environment.

Still on the left Project tab, find the ENVIRONMENTS field and click the “Prepare All Environments” button next to the Add (+) icon.

../../_images/ae51-prepenv.png

Run the Notebook

Click the left Files tab, then double-click “markowitz.ipynb” to open the notebook.

Run Cells

Click the top “Notebook” menu, and from the drop-down select “Run All Cells”.

../../_images/ae51-gs-runnotebook.png

NOTE: You will get an import error if your notebook is not linked to the project environment.

Switch to Classic Notebook

Since JupyterLab does not support inline Bokeh yet, we need to switch to Classic Notebook to view our plots.

Click the 3 dots at the top right and select “Switch to Classic Notebook”

../../_images/ae52-switch-to-notebook.png

Run Cells in Notebook

Click “markowitz_notebook” to open the notebook.

Click the top “Cell” menu, and from the drop-down select “Run All”.

../../_images/ae52-notebook-classic-run-all-cells.png

Scroll down to see and interact with the plots that you just created.

Switch back to JupyterLab

Click the 3 dots at the top right and select “Switch to JupyterLab”.

Deploy the Project

To deploy your project, you will add a deployable command and commit the changes, then leave the editing session and deploy using the Anaconda Enterprise interface.

Add a deploy command

Any project you want to deploy needs to have a deployable command for it to run.

From the left Project tab (not Commands tab), find the “COMMANDS” field and click its Add (+) icon.

In the Type section click “Notebook”

In the Name box enter “default”

In the notebook box enter “markowitz.ipynb”

Click the Save button.

../../_images/ae50-deploy.png

Commit changes and exit

In the top navigation bar on the far right, click the Commit icon.

../../_images/ae511-commit-icon.png

Check the “Tag as Deployable Revision” checkbox and click Commit Changes.

../../_images/ae52-commit-as-deployable.png

Then exit the Notebook with the “Back to finance_notebook” link on the top left corner. This brings you back to the Project Detail page.

Deploy it

Click the left Deploy tab, then click the Deploy button to deploy the Project.

While it is deploying, you can click the Deployment History tab to see a counter. A notification will tell you it has deployed.

Interact with Deployment

Time to play with your Deployment! In the Deployments list, click the name of your new Deployment to view and interact with it.

From the left View tab you can choose Cell, All Output, and Clear to clear the output. Then run all cells in your notebook with Cell and Run All.

Share your Deployment

In the Deployments list, click the name of the Deployment to share, then click the Share tab. In the box that appears, begin typing the username of your collaborator with whom you wish to share, select their name from the drop-down list and click the Share button.

Your collaborator appears in the Existing Collaborators list below.

../../_images/ae52-gs-share-deployment.png

When your collaborator logs onto Enterprise, they will see the new Deployment in their Deployments list.

What’s next?

Now that you’ve spent a little time with Anaconda Enterprise, try out the * tutorials.

You can also dig deeper with the following: